formula para calculo de mayor igual o menor

Solo consultas sobre Funciones y Fórmulas Excel.

Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Compartir en:
     

formula para calculo de mayor igual o menor

Notapor chicoleto » 21 Mar 2013 18:41

hola, algien sabria como puedo calcular un numero en funcio del valor si es menor igual o mayor.

porcentaje <100 <0.95 <0.90 <0.85
multiplicador 0,50 € 0,75 € 1,00 € 1,50 €

me explico , si un numero X es mayor que 100 se multiplique por 0.5 si es mayor que 0.95 se multiplique por 0.50€, si es mayorr de 0.90 se multiplique por 0.75 si es mayor que 0.85 se multiplique por 1

gracias por adelantado
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
chicoleto
Miembro Nuevo
Miembro Nuevo
 
Registrado: 21 Mar 2013 18:30

Re: formula para calculo de mayor igual o menor

Notapor ServandoV » 21 Mar 2013 23:55

Hola chicoleto:
Para este tipo de problemas es ideal el uso de BUSCARV() usando el 4to argumento como VERDADERO (1), (o la ausencia de él).

Ve el adjunto y nos comentas, juega con los rangos de la tabla, esa es la mejor forma de aprender su funcionamiento.

Saludos
Servando Villalón
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
Avatar de Usuario
ServandoV
Miembro Frecuente
Miembro Frecuente
 
Registrado: 14 May 2012 20:02
Ubicación: México

Re: formula para calculo de mayor igual o menor

Notapor chicoleto » 22 Mar 2013 04:09

ante todo gracias, pero el problema es que no tengo ni puede crar una tabla donde bucacar, los valores son esos ya que en la celda divide un numero y el resultado es el que quiero que comparr con menor igual o mayor y lo multiplique por la constante, seria como un si anidado lo que me ocurre es que cuando cambia de porcentaje sigue multiplicando por la misma variable .

=SI(D26>5;D13*1;SI(D26>7,5;D13*1,25;SI(D26>10;D13*1,5;SI(D26>15;D13*2))))

es algo asi pero me falta algo, un saludo
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
chicoleto
Miembro Nuevo
Miembro Nuevo
 
Registrado: 21 Mar 2013 18:30

Re: formula para calculo de mayor igual o menor

Notapor HBanchieri » 22 Mar 2013 10:47

Hola

Quiza sea algo más o menos así:

Código: Seleccionar todo
=SI(D26<0,85;1,5;SI(Y(D26>=0,85;D26<0,9);1;SI(Y(D26>=0,9;D26<0,95);0,75;SI(D26<1;0,5;0))))


OJO!!!

Amigo chicoleto, conforme la lógica natural del universo, de la matemática (RAE), y de la ascendencia numérica, después de 0,85; 0,90; 0,95; vendría el "1" (este valor le puse a la formula) y no el 100, como propones.
Te hago alerto porque una equivocación de este tipo puede alterar, y mucho, un resultado.

Saludos
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
HBanchieri
Miembro Frecuente
Miembro Frecuente
 
Registrado: 20 Mar 2011 00:33
Ubicación: Sta. Cruz - Bolivia

Re: formula para calculo de mayor igual o menor

Notapor ServandoV » 22 Mar 2013 11:41

Hola chicoleto (y HBanchieri):

Ve entonces el adjunto nuevamente y observa la función en la celda E26.

No dejes de comentarnos si esto satisface tu requerimiento.

Saludos
servando Villalón
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
Avatar de Usuario
ServandoV
Miembro Frecuente
Miembro Frecuente
 
Registrado: 14 May 2012 20:02
Ubicación: México

Re: formula para calculo de mayor igual o menor

Notapor HBanchieri » 22 Mar 2013 18:58

Señores

Mirando la formula de ServandoV me doy cuenta que para elaborar mi formula yo tome en cuenta esta explicación inicial de chicoleto:
Código: Seleccionar todo
porcentaje    <100 <0.95   <0.90   <0.85
multiplicador   0,50 €   0,75 €   1,00 €   1,50


Por esto no le puse el "1" como "valor_si_falso"

Y, sorpresa!!!

De ahi para adelante la cosa dio un vuelco, de menor para mayor.

En todo caso se tendría que cambiara los signos < por >, y viceversa, yo creo.

Saludos.
* Te recomendamos estos productos Excel: Manual de Macros | Manual de Funciones | Nuevas Funciones | ddTraDa
HBanchieri
Miembro Frecuente
Miembro Frecuente
 
Registrado: 20 Mar 2011 00:33
Ubicación: Sta. Cruz - Bolivia


Compartir en:
     

  • Anuncio
Manual Excel avanzado

Volver a Funciones y Fórmulas

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 5 invitados