La función Excel BUSCARV

BUSCARV (en inglés VLOOKUP) es una de las funciones más útiles de Excel, y es también una de las menos comprendidas. En este artículo vamos a explicarte fácilmente BUSCARV por medio de un simple ejemplo paso a paso.

1. La lógica detrás de la función BUSCARV

Veamos la siguiente imagen para comprender un caso típico de uso de BUSCARV

BUSCARV1

La función BUSCARV nos permite hacer una búsqueda de un elemento concreto
dentro de una tabla (en nuestro caso buscamos el código de producto 602)
y una vez encontrado nos devuelve otros elementos asociados al mismo
(en nuestro caso nos dirá que corresponde al producto Tornillo 30 mm
y que su stock es de 34 unidades)

2. La sintaxis de la función BUSCARV

La sintaxis (forma de escribir) BUSCARV es sencilla y solo requiere 4 argumentos:

= BUSCARV (valor buscado; tabla de búsqueda; columna de búsqueda; ¿tabla ordenada?)

BUSCARV2

En nuestro ejemplo, la fórmula que usamos en celda G3 para buscar el Producto es:

=BUSCARV(G2;B2:D12;2;FALSO)

Buscar el valor del código indicado en G2 (lo que buscamos puntualmente) En la tabla de B2:D12  (dónde lo buscamos)
y devolver el valor de la columna 2 de dicha tabla (columna que contiene lo que buscamos)
¿la tabla está ordenada? FALSO (siempre conviene poner falso)

La fórmula que usamos para buscar el Stock es similar,
con la única diferencia que en el 3er argumento,
la columna que contiene lo que buscamos es la 3 en lugar de la 2

3. Lo que debemos recordar de la función BUSCARV

Todo comienza con un elemento buscado

Puede ser un código de producto, de cliente, un nombre de proveedor, un N° de reclamo, etc

La función BUSCARV siempre entra de forma vertical por la primer columna de la tabla,
y cuando encuentra el elemento buscado se mueve de forma horizontal al N° de columna indicado

El N° de columna es la columna que contiene la información requerida para el elemento buscado
(en nuestro ejemplo el nombre de producto y el stock del mismo)

El N° de columna hace referencia al N° de columna de la tabla no de la hoja!

Respecto del último argumento siempre conviene poner FALSO
FALSO indica que la tabla puede no estar ordenada
Si lo omitimos y la tabla está desordenada podemos tener un resultado incorrecto
Para mayor seguridad siempre poner FALSO

Si la función BUSCARV no encuentra lo que busca devuelve el error #N/A
Para evitar el error #N/A podemos anteponer la función SI.ERROR que explicaremos + adelante

¿Deseas descargar los ejemplos?

Completa tus datos para recibir esta descarga

Recibe avisos de nuevas descargas, trucos y tutoriales Excel